Wissensdatenbank
POSH GmbH > Support-Center > Wissensdatenbank

Suchbegriff(e)


Schritt-für-Schritt : DXF/DWG-Import

Lösung

vor dem DXF/DWG-Import:

  1. Einheiten: DXF/DWG-Daten sind generell dimensionslos, d.h. es liegen nur Koordinaten der Zeichnungselemente ohne Information bez. der vom Ersteller verwendeten Einheit vor.

  2. Vor dem Import von DXF/DWG-Daten muss daher die bekannte oder vermutete Einheit (z.B. Maschinenbau = Millimeter o. Architektur = Meter) unter "Layout > Einstellungen > Maßeinheiten..." eingestellt werden.

  3. Maßstab: für eine optimale Übernahme der Größen-Formatierung von Texten und Bemassungstexten vor dem Import den Zeichnungsmaßstab auf "1:1" stellen: "Layout > Zeichnungsgröße... > Zeichnungsmaßstab"


DXF/DWG-Import:

  1. Befehl "Datei > Import > DXF/DWG ..." ausführen, dabei die 4 optionalen DXF/DWG Import-Optionen deaktiviert lassen.

nach dem DXF/DWG-Import:

  1. Kontrolle: vor einer weiteren Verwendung oder Bearbeitung der Zeichnung die Abmessungen der importierten Geometrien kontrollieren.

    Dazu ein beliebiges Zeichnungselement wie z.B. eine Linie markieren und im Eigenschaften-Fenster (Win: Strg+I / Mac: Apfel+I) die Längenangabe unter Beachtung der eingestellten Masseinheit (s.o.) kontrollieren: "Bearbeiten > Objekte bearbeiten > Länge..."

  2. Korrektur: falls die angezeigte Länge, z.B. durch den Import einer Meter-Zeichnung in der Maßeinheit Millimeter (s.o.), um ein oder mehrere 10er-Potenzen abweichend ist, die komplette Geometrie z.B. per Win: Strg+A bzw. Apfel-A oder Doppeklick auf das Markieren-Werkzeug markieren und mit dem Skalieren-Werkzeug um den gewünschten Faktor vergrössern bzw. verkleinern.

    Die Konstruktion liegt nun in 'wahren' Abmaßen vor und kann somit auch korrekt bemaßt werden.

  3. Korrektur: um zu vermeiden, dass der Zeichen-Assistent auf eventuell importierte 3D Geometrie referenziert, d.h. Fangpunkte mit z-Koordinaten fängt, können die dreidimensionalen Anteile einer Zeichnung ggf. entfernt werden:

    • um z-Koordinaten in der Unlimited-Version zu entfernen, den externen Befehl "z-Koordinate entfernen" unter "Extras > Befehle einbinden.." einbinden und aus dem Extras-Menü ausführen.

    • um z-Koordinaten in der Expert-/Professional-Version zu entfernen, den Befehl "Anordnen > Entferne z-Koordinaten" ausführen.


Sollte der Ersteller der DXF/DWG-Daten bei aktivem Modellbereich (= Konstruktions-Ansicht) abgespeichert haben, muss für eine Darstellung des Papierbereiches (= Laoyut-Ansicht inkl. z.B. Zeichnungsrahmen/Zeichenkopf) in der DraftBoard Hauptansicht das zugehörige Modell ausgewählt werden. Dazu nach dem Import unter "Ansichten > Modelle" das Modell des Papierbereichs auswählen (bei leerer Zeichnung i.d.R. "Modell 1") und aktuell setzen. Die Detailansicht mit der Ansicht des Modellbereichs darf dazu nicht aktiv sein (= grauer Querbalken nicht sichtbar).


Sollten nach dem Import das Dokument ein inkonsistentes Verhalten wie z.B. ein nicht reagierender Objektfang oder Probleme bei einem folgenden DXF/DWG-Export zeigen, ist eine Kontrolle auf unsichtbare Block-Einfügepunkte und Null-Längen Objekte im Ursprung der Zeichnung empfehlenswert.

Dazu einfach mit dem Selektieren-Werkzeug ein Fenster über den Ursprung bzw. Nullpunkt der ziehen und im Eigenschaften-Fenster (Win: Strg+I / Mac: Apfel+I) auf eventuell selektierte Objekte prüfen und ggf. löschen.


Für eine Kontrolle von erhaltenen oder selbst erzeugten DXF/DWG-Daten bzw. für eine Konvertierung von oder in jüngere DXF/DWG-Formaten können Hilfs-Programme externer Anbieter verwendet werden. Eine Auflistung diverser Produkte finden Sie in der Sektion "DXF/DWG" unserer Web Links Liste.

Verwandte Artikel Abmessungen von Geometrie inkorrekt
Absturz bei DXF/DWG-Export
Zeichnung im Ursprung platzieren
Bitmap BMP-Import erzeugt grauen Streifen [WIN]
Zeichen-Assistent ohne Funktion
Artikeldetails
Artikel-ID: 3
Kategorie: Bedienung & Konfiguration
Datum (erstellt): 19.11.2010 - 17:36:11
Aufrufe: 1012

 
« Zurück